Show patches with: none      |   3682 patches
« 1 2 3 436 37 »
Patch Series A/R/T S/W/F Date Submitter Delegate State
[wrynose,2.18,4/4] tests/fetch: Swap bitbake github mirror for YP one [wrynose,2.18,1/4] data: Return a list from exported_vars() - - - --- 2026-09-09 Yoann Congal New
[wrynose,2.18,3/4] tests/fetch: Swap github grpc repo for our own small test repo [wrynose,2.18,1/4] data: Return a list from exported_vars() - - - --- 2026-09-09 Yoann Congal New
[wrynose,2.18,2/4] fetch/gitsm: Store the original url data to fix relative gitsm paths [wrynose,2.18,1/4] data: Return a list from exported_vars() - - - --- 2026-09-09 Yoann Congal New
[wrynose,2.18,1/4] data: Return a list from exported_vars() [wrynose,2.18,1/4] data: Return a list from exported_vars() - - - --- 2026-09-09 Yoann Congal New
[wrynose,2.18,0/4] Patch review - - - --- 2026-09-09 Yoann Congal Not Applicable
[2/2] asyncrpc/serv: Add missing import [1/2] tests/fetch: Switch to YP mirror repos instead of github - - - --- 2026-09-08 Richard Purdie Accepted
[1/2] tests/fetch: Switch to YP mirror repos instead of github [1/2] tests/fetch: Switch to YP mirror repos instead of github - - - --- 2026-09-08 Richard Purdie Accepted
bin/bitbake-setup: print a note about fetcher log if something fails there bin/bitbake-setup: print a note about fetcher log if something fails there - - - --- 2026-09-07 Alexander Kanavin Accepted
[2/2] lib/bb/_vendor: resync to add tomli [1/2] vendor.txt: add tomli - - - --- 2026-09-07 Ross Burton Accepted
[1/2] vendor.txt: add tomli [1/2] vendor.txt: add tomli - - - --- 2026-09-07 Ross Burton Accepted
tests/fetch: Drop ftp checkstatus test tests/fetch: Drop ftp checkstatus test - - - --- 2026-09-07 Richard Purdie Accepted
[v2] tests/fetch: Swap bitbake github mirror for YP one [v2] tests/fetch: Swap bitbake github mirror for YP one - - - --- 2026-09-07 Richard Purdie Accepted
tests/fetch: Swap bitbake github mirror for YP one tests/fetch: Swap bitbake github mirror for YP one - - - --- 2026-09-07 Richard Purdie Accepted
doc/bitbake-user-manual-metadata: move := section before ??= doc/bitbake-user-manual-metadata: move := section before ??= - - - --- 2026-09-07 Antonin Godard Accepted
[2/2] tests/fetch: Swap github grpc repo for our own small test repo [1/2] fetch/gitsm: Store the original url data to fix relative gitsm paths - - - --- 2026-09-07 Richard Purdie Accepted
[1/2] fetch/gitsm: Store the original url data to fix relative gitsm paths [1/2] fetch/gitsm: Store the original url data to fix relative gitsm paths - - - --- 2026-09-07 Richard Purdie Accepted
fetch2/git: Clarify error about missing LFS support fetch2/git: Clarify error about missing LFS support - - - --- 2026-09-02 Peter Kjellerstedt Accepted
[2.18,5/5] bb/tests/fetch.py: add case for filter_regex parameter in latest_versionstring Add case for filter_regex parameter in latest_versionstring - - - --- 2026-09-02 Daniel Turull ycongal_smile Under Review
[2.18,4/5] fetch2/__init__.py: add filter_regex to default latest_versionstring Add case for filter_regex parameter in latest_versionstring - - - --- 2026-09-02 Daniel Turull ycongal_smile Under Review
[2.18,3/5] fetch2/crate.py: add filter_regex parameter to latest_versionstring Add case for filter_regex parameter in latest_versionstring - - - --- 2026-09-02 Daniel Turull ycongal_smile Under Review
[2.18,2/5] fetch2/wget.py: add filter_regex parameter to latest_versionstring Add case for filter_regex parameter in latest_versionstring - - - --- 2026-09-02 Daniel Turull ycongal_smile Under Review
[2.18,1/5] fetch2/git.py: add filter_regex parameter to latest_versionstring Add case for filter_regex parameter in latest_versionstring - - - --- 2026-09-02 Daniel Turull ycongal_smile Under Review
[RFC] fetch: `touch` mirror tarball stamp files on download [RFC] fetch: `touch` mirror tarball stamp files on download - - - --- 2026-09-02 Philip Lorenz New
fetch2: Raise on git lfs fetch failures fetch2: Raise on git lfs fetch failures - - - --- 2026-09-02 Philip Lorenz Accepted
[5/5] toaster/tests/layerdetails: Update tests to use labels and scrolling function [1/5] toaster: Rename wait_until_element_clickable -> wait_under_finder_clickable - - - --- 2026-09-01 Richard Purdie Accepted
[4/5] tests/selenium_helpers_base: Add wait_until_element_clickable [1/5] toaster: Rename wait_until_element_clickable -> wait_under_finder_clickable - - - --- 2026-09-01 Richard Purdie Accepted
[3/5] toaster/layerdetails: Add id labels to for to make tests more robust [1/5] toaster: Rename wait_until_element_clickable -> wait_under_finder_clickable - - - --- 2026-09-01 Richard Purdie New
[2/5] toaster: Update to django 5.2 [1/5] toaster: Rename wait_until_element_clickable -> wait_under_finder_clickable - - - --- 2026-09-01 Richard Purdie Accepted
[1/5] toaster: Rename wait_until_element_clickable -> wait_under_finder_clickable [1/5] toaster: Rename wait_until_element_clickable -> wait_under_finder_clickable - - - --- 2026-09-01 Richard Purdie New
[RFC] parse/ast: add support for additive built-in fragments [RFC] parse/ast: add support for additive built-in fragments - - - --- 2026-09-01 Antonin Godard New
default-registry: use core/yocto/monitor-disk-space fragment by default default-registry: use core/yocto/monitor-disk-space fragment by default - - - --- 2026-08-31 Antonin Godard Accepted
[2.8] fetch2/gcp: treat GatewayTimeout as fetch failure [2.8] fetch2/gcp: treat GatewayTimeout as fetch failure - - - --- 2026-08-31 Etienne Cordonnier New
doc: continue the eventmask example onto its second line doc: continue the eventmask example onto its second line - - - --- 2026-08-31 Trevor Woerner Accepted
doc: document the conventions used in the manual doc: document the conventions used in the manual - - - --- 2026-08-31 Trevor Woerner New
doc: quote the value in the named-checksum example doc: quote the value in the named-checksum example - - - --- 2026-08-31 Trevor Woerner Accepted
fetch2/wget: remove orphaned NamedTemporaryFile in _fetch_index fetch2/wget: remove orphaned NamedTemporaryFile in _fetch_index - - - --- 2026-08-30 AdrianF Accepted
[2/2] toaster/orm/lsupdates: Improve error handling [1/2] toaster/tests: Add and use wait_until_element_visible() - - - --- 2026-08-28 Richard Purdie Accepted
[1/2] toaster/tests: Add and use wait_until_element_visible() [1/2] toaster/tests: Add and use wait_until_element_visible() - - - --- 2026-08-28 Richard Purdie Accepted
[v2,4/4] doc: update manual to reflect bb.fetch2 => bb.fetch migration [v2,1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch - - - --- 2026-08-28 chris.laplante@agilent.com Accepted
[v2,3/4] tests: add fetch_import tests to test bb.fetch2 => bb.fetch migration [v2,1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch - - - --- 2026-08-28 chris.laplante@agilent.com Accepted
[v2,2/4] bin, lib, conf: use bb.fetch instead of bb.fetch2 [v2,1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch - - - --- 2026-08-28 chris.laplante@agilent.com Accepted
[v2,1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch [v2,1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch - - - --- 2026-08-28 chris.laplante@agilent.com Accepted
[bitbake-devel,v3,11/11] hashserv: server: Fix upstream get-unihash miss truncating stream hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,10/11] hashserv: tests: Add test for upstream pipelining hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,09/11] hashserv: tests: Add more upstream tests hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,08/11] hashserv: server: Use streaming and queue API for upstream exist queries hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,07/11] hashserv: server: Use streaming and queue API for upstream unihash queries hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,06/11] hashserv: server: Add queued streaming API hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,05/11] hashserv: client: Add asynchronous streaming API hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,04/11] hashserv: tests: Improve test logging hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,03/11] asyncrpc: serv: Cancel all clients on server stop hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,02/11] asyncrpc: serv: Use Task Group hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
[bitbake-devel,v3,01/11] asyncrpc: Add Task Group hashserv: Pipeline Upstream Queries - - - --- 2026-08-28 Joshua Watt New
bin/toaster: Remove accidentally added version string bin/toaster: Remove accidentally added version string - - - --- 2026-08-28 Richard Purdie Accepted
[v2,11/11] runqueue: report memory pressure limit correctly runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,10/11] runqueue: clean up dumpsigs polling runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,09/11] runqueue: wait for covered tasks before setscene runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,08/11] runqueue: fix remaining attributes created outside of constructor runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,07/11] runqueue: declare pressure/load attributes in RunQueueScheduler.__init__ rather than dyn… runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,06/11] runqueue: optimize construction of rev_prio_map runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,05/11] runqueue: remove RunQueueExecute.build_stamps2 which is never read runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,04/11] runqueue: cleanup imports runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,03/11] runqueue: remove long-unused RunQueueData get_user_idstring/get_short_user_idstring runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,02/11] runqueue: remove unused RunQueueExecute.sorted_setscene_tids; declare setscene_tids_gene… runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[v2,01/11] runqueue: remove unused attributes/variables runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[11/11] runqueue: report memory pressure limit correctly runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[10/11] runqueue: clean up dumpsigs polling runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[09/11] runqueue: wait for covered tasks before setscene runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[08/11] runqueue: fix remaining attributes created outside of constructor runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[07/11] runqueue: declare pressure/load attributes in RunQueueScheduler.__init__ rather than dynami… runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[06/11] runqueue: optimize construction of rev_prio_map runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[05/11] runqueue: remove RunQueueExecute.build_stamps2 which is never read runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[04/11] runqueue: cleanup imports runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[03/11] runqueue: remove long-unused RunQueueData get_user_idstring/get_short_user_idstring runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[02/11] runqueue: remove unused RunQueueExecute.sorted_setscene_tids; declare setscene_tids_generat… runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[01/11] runqueue: remove unused attributes/variables runqueue correctness fixes, optimizations, and cleanups - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[4/4] doc: update manual to reflect bb.fetch2 => bb.fetch migration [1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[3/4] tests: add fetch_import tests to test bb.fetch2 => bb.fetch migration [1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[2/4] bin, lib, conf: use bb.fetch instead of bb.fetch2 [1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
[1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch [1/4] lib: rename fetch2 as fetch; invert compat shim to make bb.fetch2 = bb.fetch - - - --- 2026-08-27 chris.laplante@agilent.com Accepted
knotty: Hide 'Bitbake still alive' message with quiet>2 knotty: Hide 'Bitbake still alive' message with quiet>2 - - - --- 2026-08-27 Rouven Rastetter New
[v2] knotty: show elapsed time on the task progress bar [v2] knotty: show elapsed time on the task progress bar - - - --- 2026-08-27 WXbet Accepted
cooker: Clean up collect_bbfiles handling cooker: Clean up collect_bbfiles handling - - - --- 2026-08-26 Richard Purdie Accepted
[4/4] doc: use the bitbake code-block language in the remaining chapters doc: highlight BitBake snippets with the bitbake language - - - --- 2026-08-26 Trevor Woerner New
[3/4] doc: bitbake-user-manual-fetching: use the bitbake code-block language doc: highlight BitBake snippets with the bitbake language - - - --- 2026-08-26 Trevor Woerner New
[2/4] doc: bitbake-user-manual-ref-variables: use the bitbake code-block language doc: highlight BitBake snippets with the bitbake language - - - --- 2026-08-26 Trevor Woerner New
[1/4] doc: bitbake-user-manual-metadata: use the bitbake code-block language doc: highlight BitBake snippets with the bitbake language - - - --- 2026-08-26 Trevor Woerner New
doc: state the language of six Python blocks explicitly doc: state the language of six Python blocks explicitly - 1 - --- 2026-08-26 Trevor Woerner New
[6/6] cookerdata: cleanup imports [1/6] data_smart: use Pattern.search instead of findall, to match comment - - - --- 2026-08-25 chris.laplante@agilent.com Accepted
[5/6] __init__.py: add missing import bb.event [1/6] data_smart: use Pattern.search instead of findall, to match comment - - - --- 2026-08-25 chris.laplante@agilent.com Accepted
[4/6] build: localize import of bb.progress [1/6] data_smart: use Pattern.search instead of findall, to match comment - - - --- 2026-08-25 chris.laplante@agilent.com Accepted
[3/6] runqueue: use set 'discard' method instead of 'in' followed by 'remove' [1/6] data_smart: use Pattern.search instead of findall, to match comment - - - --- 2026-08-25 chris.laplante@agilent.com Accepted
[2/6] runqueue: fix init of RunQueueScheduler.prio_map; add test for 'basic' scheduler [1/6] data_smart: use Pattern.search instead of findall, to match comment - - - --- 2026-08-25 chris.laplante@agilent.com Accepted
[1/6] data_smart: use Pattern.search instead of findall, to match comment [1/6] data_smart: use Pattern.search instead of findall, to match comment - - - --- 2026-08-25 chris.laplante@agilent.com Accepted
[2.18,2/2] tests/fetch: restore and extend npm/npmsw test coverage fetch/{npm,npmsw}: fix security issue and re-enable fetchers - - - --- 2026-08-25 Antonin Godard ycongal_smile Rejected
[2.18,1/2] fetch/{npm,npmsw}: re-enable fetchers now that checksums come from SRC_URI fetch/{npm,npmsw}: fix security issue and re-enable fetchers - - - --- 2026-08-25 Antonin Godard ycongal_smile Rejected
[2.18] data: Return a list from exported_vars() [2.18] data: Return a list from exported_vars() - - - --- 2026-08-24 Alejandro Mery ycongal_smile Under Review
[v2] doc/bitbake-user-manual-ref-variables: document PREFERRED_RPROVIDER [v2] doc/bitbake-user-manual-ref-variables: document PREFERRED_RPROVIDER - - - --- 2026-08-24 Yann Dirson Accepted
runqueue: fix bad check in process_possible_migrations runqueue: fix bad check in process_possible_migrations - - - --- 2026-08-24 chris.laplante@agilent.com Accepted
[v2] fetch2/git: replace stale clones when using premirrors [v2] fetch2/git: replace stale clones when using premirrors - - - --- 2026-08-24 Fredrik Svensson (svsvenss) New
« 1 2 3 436 37 »