mbox series

[0/3] Remove bb.fetch compatibility shim module

Message ID 20260821170624.436725-1-chris.laplante@agilent.com
Headers show
Series Remove bb.fetch compatibility shim module | expand

Message

chris.laplante@agilent.com Aug. 21, 2026, 5:06 p.m. UTC
From: Chris Laplante <chris.laplante@agilent.com>

fetch2 replaced fetch a long time ago (2012) so I argue it is time to
say goodbye the bb.fetch shim.

Chris Laplante (3):
  bin/bitbake-setup: use bb.fetch2, not bb.fetch
  lib: use bb.fetch2, not bb.fetch
  lib: remove bb.fetch shim module; cleanup fallout

 bin/bitbake-setup         |  20 ++--
 lib/bb/__init__.py        |   4 +-
 lib/bb/build.py           |   2 +-
 lib/bb/command.py         |   2 +-
 lib/bb/cooker.py          |   6 +-
 lib/bb/cookerdata.py      |  13 +-
 lib/bb/fetch2/gitannex.py |   8 +-
 lib/bb/fetch2/wget.py     |   6 +-
 lib/bb/tests/fetch.py     | 244 +++++++++++++++++++-------------------
 9 files changed, 155 insertions(+), 150 deletions(-)

--
2.43.0

Comments

Alexander Kanavin Aug. 21, 2026, 5:17 p.m. UTC | #1
On Fri, 21 Aug 2026 at 19:06, Chris Laplante via
lists.openembedded.org
<chris.laplante=agilent.com@lists.openembedded.org> wrote:
> fetch2 replaced fetch a long time ago (2012) so I argue it is time to
> say goodbye the bb.fetch shim.

Why not instead rename fetch2 to fetch and drop the unneeded '2'? Is
there a reason to keep the number?

Alex
chris.laplante@agilent.com Aug. 21, 2026, 5:26 p.m. UTC | #2
Hi Alex,

> On Fri, 21 Aug 2026 at 19:06, Chris Laplante via lists.openembedded.org
> <chris.laplante=agilent.com@lists.openembedded.org> wrote:
> > fetch2 replaced fetch a long time ago (2012) so I argue it is time to
> > say goodbye the bb.fetch shim.
> 
> Why not instead rename fetch2 to fetch and drop the unneeded '2'? Is there a
> reason to keep the number?

I thought about it, but I'd bet 'fetch2' is more prevalent than 'fetch' in third-party layers. We also document the naming choice: https://docs.yoctoproject.org/bitbake/bitbake-user-manual/bitbake-user-manual-fetching.html#file-download-support. So I think it would result in breaking a bunch of layers. Whereas if people are still using bb.fetch, we can point to the manual if they complain. 

That being said, I'm not opposed to going the 'fetch' route if people prefer it.  

Thanks,
Chris
Richard Purdie Aug. 21, 2026, 9:27 p.m. UTC | #3
On Fri, 2026-08-21 at 17:26 +0000, Chris Laplante via lists.openembedded.org wrote:
> Hi Alex,
> 
> > On Fri, 21 Aug 2026 at 19:06, Chris Laplante via lists.openembedded.org
> > <chris.laplante=agilent.com@lists.openembedded.org> wrote:
> > > fetch2 replaced fetch a long time ago (2012) so I argue it is time to
> > > say goodbye the bb.fetch shim.
> > 
> > Why not instead rename fetch2 to fetch and drop the unneeded '2'? Is there a
> > reason to keep the number?
> 
> I thought about it, but I'd bet 'fetch2' is more prevalent than
> 'fetch' in third-party layers. We also document the naming choice:
> https://docs.yoctoproject.org/bitbake/bitbake-user-manual/bitbake-user-manual-fetching.html#file-download-support
> . So I think it would result in breaking a bunch of layers. Whereas
> if people are still using bb.fetch, we can point to the manual if
> they complain. 
> 
> That being said, I'm not opposed to going the 'fetch' route if people
> prefer it.  

I'd probably lean towards moving to "bb.fetch" but leaving fetch2
working for a short while as things get updated. The "2" is fairly
meaningless.

The key question is whether we'd ever have a fetch3 but I suspect we'd
handle things differently with fetcher changes than that...

Cheers,

Richard