diff mbox series

[1/2] iniparser: upgrade 4.2 -> 4.2.1

Message ID 20240522111348.6109-2-openembedded@moellendorf.eu
State Accepted
Headers show
Series iniparser upgrade | expand

Commit Message

Lars Möllendorf May 22, 2024, 11:13 a.m. UTC
From: Lars Möllendorf <lars.moellendorf@plating.de>

Hompage-Upgrade: upstream iniparser moved to Gitlab


Add-CMake-support.patch
removed since CMake support is now provided upstream

0001-iniparser.pc-Make-libpath-a-variable.patch
removed since pkg-config file is now generated by CMake

Signed-off-by: Lars Möllendorf <lars.moellendorf@plating.de>
---
 ...iniparser.pc-Make-libpath-a-variable.patch | 23 -------
 .../iniparser/Add-CMake-support.patch         | 65 -------------------
 .../iniparser/iniparser_4.2.2.bb              | 16 +++++
 .../iniparser/iniparser_4.2.bb                | 27 --------
 4 files changed, 16 insertions(+), 115 deletions(-)
 delete mode 100644 meta-oe/recipes-support/iniparser/iniparser/0001-iniparser.pc-Make-libpath-a-variable.patch
 delete mode 100644 meta-oe/recipes-support/iniparser/iniparser/Add-CMake-support.patch
 create mode 100644 meta-oe/recipes-support/iniparser/iniparser_4.2.2.bb
 delete mode 100644 meta-oe/recipes-support/iniparser/iniparser_4.2.bb
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/iniparser/iniparser/0001-iniparser.pc-Make-libpath-a-variable.patch b/meta-oe/recipes-support/iniparser/iniparser/0001-iniparser.pc-Make-libpath-a-variable.patch
deleted file mode 100644
index 4824344f0..000000000
--- a/meta-oe/recipes-support/iniparser/iniparser/0001-iniparser.pc-Make-libpath-a-variable.patch
+++ /dev/null
@@ -1,23 +0,0 @@ 
-From 1761298b73c759c07e4652ada307f68512a75ff1 Mon Sep 17 00:00:00 2001
-From: Khem Raj <raj.khem@gmail.com>
-Date: Fri, 25 Mar 2022 20:44:41 -0700
-Subject: [PATCH] iniparser.pc: Make libpath a variable
-
-Will set according to baselib that yocto exports.
-
-Upstream-Status: Inappropriate [OE-specific]
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
----
- iniparser.pc | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/iniparser.pc
-+++ b/iniparser.pc
-@@ -1,6 +1,6 @@
- prefix=/usr
- exec_prefix=/usr
--libdir=${exec_prefix}/lib
-+libdir=${exec_prefix}/@baselib@
- includedir=${prefix}/include
- datarootdir=${prefix}/share
- datadir=${datarootdir}
diff --git a/meta-oe/recipes-support/iniparser/iniparser/Add-CMake-support.patch b/meta-oe/recipes-support/iniparser/iniparser/Add-CMake-support.patch
deleted file mode 100644
index 46c1b0f7a..000000000
--- a/meta-oe/recipes-support/iniparser/iniparser/Add-CMake-support.patch
+++ /dev/null
@@ -1,65 +0,0 @@ 
-Origin: Debian packaging
-From: Klee Dienes <klee@mit.edu>
-Date: Thu, 13 Feb 2014 07:03:26 -0500
-Subject: Add CMake support.
-
----
-Upstream-Status: Pending
-
- CMakeLists.txt | 44 ++++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 44 insertions(+)
- create mode 100644 CMakeLists.txt
-
---- /dev/null
-+++ b/CMakeLists.txt
-@@ -0,0 +1,50 @@
-+cmake_minimum_required (VERSION 2.8.8)
-+
-+project (iniparser)
-+include (GNUInstallDirs)
-+
-+include_directories (src)
-+
-+set(INIPARSER_SRCS src/dictionary.c src/iniparser.c)
-+set(INIPARSER_HDRS src/dictionary.h src/iniparser.h)
-+
-+add_library(iniparser-shared SHARED ${INIPARSER_SRCS} ${INIPARSER_HDRS})
-+add_library(iniparser-static STATIC ${INIPARSER_SRCS} ${INIPARSER_HDRS})
-+
-+set_target_properties(iniparser-shared PROPERTIES SOVERSION 1)
-+set_target_properties(iniparser-shared PROPERTIES OUTPUT_NAME iniparser)
-+set_target_properties(iniparser-static PROPERTIES OUTPUT_NAME iniparser)
-+
-+install (TARGETS iniparser-shared
-+  LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+  DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+  ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+
-+install (TARGETS iniparser-static
-+  LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+  DESTINATION ${CMAKE_INSTALL_LIBDIR}
-+  ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
-+
-+find_package(Doxygen)
-+if (NOT DOXYGEN_FOUND)
-+message(FATAL_ERROR "Doxygen is needed to build the documentation. Please install it correctly")
-+endif()
-+
-+file (WRITE ${CMAKE_CURRENT_BINARY_DIR}/iniparser.dox
-+  "@INCLUDE = ${CMAKE_CURRENT_SOURCE_DIR}/doc/iniparser.dox\n"
-+  "OUTPUT_DIRECTORY = ${CMAKE_CURRENT_BINARY_DIR}\n"
-+  )
-+
-+add_custom_target (doc ALL 
-+  COMMAND ${DOXYGEN_EXECUTABLE} ${CMAKE_CURRENT_BINARY_DIR}/iniparser.dox
-+  SOURCES doc/iniparser.dox)
-+
-+enable_testing()
-+
-+add_test(NAME testsuite
-+  COMMAND make
-+  WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}/test)
-+
-+install (FILES ${INIPARSER_HDRS} DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/iniparser)
-+
-+install (DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION ${CMAKE_INSTALL_DOCDIR})
diff --git a/meta-oe/recipes-support/iniparser/iniparser_4.2.2.bb b/meta-oe/recipes-support/iniparser/iniparser_4.2.2.bb
new file mode 100644
index 000000000..a8f7947c8
--- /dev/null
+++ b/meta-oe/recipes-support/iniparser/iniparser_4.2.2.bb
@@ -0,0 +1,16 @@ 
+SUMMARY = "The iniParser library is a simple C library offering INI file parsing services (both reading and writing)."
+SECTION = "libs"
+HOMEPAGE = "https://gitlab.com/iniparser/iniparser"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=8474d3b745f77e203f1fc82fb0bb7678"
+SRCBRANCH = "main"
+SRCREV = "v${PV}"
+
+DEPENDS = "doxygen-native"
+
+SRC_URI = "git://gitlab.com/iniparser/iniparser.git;protocol=https;branch=${SRCBRANCH}"
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+FILES_${PN}-staticdev += "${libdir}/cmake/iniparser/iniparser-staticTargets*.cmake"
diff --git a/meta-oe/recipes-support/iniparser/iniparser_4.2.bb b/meta-oe/recipes-support/iniparser/iniparser_4.2.bb
deleted file mode 100644
index d44772590..000000000
--- a/meta-oe/recipes-support/iniparser/iniparser_4.2.bb
+++ /dev/null
@@ -1,27 +0,0 @@ 
-SUMMARY = "The iniParser library is a simple C library offering INI file parsing services (both reading and writing)."
-SECTION = "libs"
-HOMEPAGE = "https://github.com/ndevilla/iniparser"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=8474d3b745f77e203f1fc82fb0bb7678"
-
-DEPENDS = "doxygen-native"
-
-PV .= "+git"
-
-SRC_URI = "git://github.com/ndevilla/iniparser.git;protocol=https;branch=master \
-           file://0001-iniparser.pc-Make-libpath-a-variable.patch \
-           file://Add-CMake-support.patch \
-"
-
-SRCREV = "9f5a6da1c245b44f49a46212ec0d81ffb1f821aa"
-
-S = "${WORKDIR}/git"
-
-inherit cmake
-
-do_install:append() {
-    install -Dm 0644 ${S}/iniparser.pc ${D}${libdir}/pkgconfig/iniparser.pc
-    sed -i -e 's,@baselib@,${baselib},g' ${D}${libdir}/pkgconfig/iniparser.pc
-}
-
-BBCLASSEXTEND += "native"