[1/2] docs: conf.py: bump minimum Sphinx version requirement

Message ID 20220705094213.68263-1-foss+yocto@0leil.net
State New
Headers show
Series [1/2] docs: conf.py: bump minimum Sphinx version requirement | expand

Commit Message

Quentin Schulz July 5, 2022, 9:42 a.m. UTC
From: Quentin Schulz <quentin.schulz@theobroma-systems.com>

extlinks captions support using %s substitution but only from sphinx
4.0 onwards. Anything before does not support the %s substitution.
However, this will be a requirement in sphinx 6.0 and later, and sphinx
5.0 already shows a warning telling us that.

Since the build is made with -W flag which fails it if any warning is
printed, a fix is required.

Sphinx 4.0.0 was released two years ago. Unfortunately, Debian packages
are out-of-date and only the latest Ubuntu has recent enough packages.
Therefore, pip installation should be recommended now instead and the
minimum version for building the docs bumped to 4.0.

Cc: Quentin Schulz <foss+yocto@0leil.net>
Signed-off-by: Quentin Schulz <quentin.schulz@theobroma-systems.com>
 documentation/conf.py | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


diff --git a/documentation/conf.py b/documentation/conf.py
index baf550e3e..8a9cbc972 100644
--- a/documentation/conf.py
+++ b/documentation/conf.py
@@ -53,7 +53,7 @@  author = 'The Linux Foundation'
 # -- General configuration ---------------------------------------------------
 # Prevent building with an outdated version of sphinx
-needs_sphinx = "3.1"
+needs_sphinx = "4.0"
 # to load local extension from the folder 'sphinx'
 sys.path.insert(0, os.path.abspath('sphinx'))